最近遇到一个项目,开发环境是wamp,最高的php版本为7.2.4。而我们使用了一个第三方的包其需要的最低php版本为7.2.5.没有办法,只能尝试升级wamp的php版本到更高的版本。

1,下载php

php7.3下载点这里 php7.3下载

需要下载自己的对应版本。注意是否为线程安全。(确认是否为线程安全,可以在先前的版本中使用phpinfo(),查看 Thread Safety 参数是否启用)

php线程安全.png

 2,设置php

2.1 将下载好的php7.3.30解压到wamp的php目录。具体路径如下:

安装php新的版本.png

2.2 从已存在的php(7.2.4)版本文件中复制以下文件:

 php.ini、phpForApache.ini和wampserver.conf到新下载的php(7.3.30)版本中

2.3 修改php.ini以及phpForApache.ini中的文件

将所有7.2.4替换成7.3.30(其他版本的一样)

2.4 重启电脑。

单单重启wamp是无效的。

 

评论 (0)

  • 最新在前
  • 最佳在前