在PHP5.3.3安装Joomla!错误

Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!
就这个错误提示,是PHP配置问题还是别的问题呢???
已邀请:

妥协 - 不会轻易妥协的人不愿意将就的人任性自由的人总是活得比较累

赞同来自:

Joomla 3.0 的时候,对主机的要求是 PHP 版本高于 5.3 即可;到了 Joomla 3.3 ,这个要求提高了:PHP 版本必须高于 5.3.10 。
你看到的那个英文提示就是告诉你,PHP 必须高于 5.3.10 才能安装 Joomla 3.3.3 核心。
请联系主机商,让他们帮你升级 PHP 版本。

跑堂小2 - 冇钱;冇房子;冇成就。要吃饭;要住宿;要消费

赞同来自:

额。。。看错了是5.3.10不是5.3.1
郁闷,这还是云主机,又要重新配置了。。。新人伤不起啊。慢慢在边学边装

追梦人 - 梦想每个人都有,但不是每个人都有勇气去坚信,我有

赞同来自:

云主机的操作系统是 CentOS 6 吧?
CentOS 官方安装包
里面,CentOS 6 自带的 PHP 最高版本正好就是 5.3.3 。因此你无法通过官方的升级指令(例如:# yum update -y)来自动升级 PHP 版本,执行该指令只能得到:No Packages marked for Update
实际上,CentOS 官方在2013年曾经升级过一次核心,只不过是针对 64位 版本。参看: http://wiki.centos.org/Additio ... s/SCL
,这次升级之后,PHP 最高版本变成了 5.4.16 。这个版本完全满足 Joomla 3.3 的要求。
安装方法(参看: https://www.virtualmin.com/doc ... lephp
):yum install centos-release-scl
yum install php54 php54-php-cli php54-php-mysql php54-php-gd

孤独者 - 世界属于那些勤于思考的人,更属于那些善于行动的人

赞同来自:

直接把云服务器重装了。正在用http://www.php100.com/html/php ... .html这个网站的教程装5.5,估计就是Joomla4都可以支持了。。呵呵

~~~~~~~~~ - 上帝给我的使命,就是证明你们都不是最糟糕的

赞同来自:

PHP 5.5 太高了,某些 Joomla 扩展安装之后可能会出错。
建议选择 PHP 5.3.10 至 5.4.31 之间的版本。

跑堂小2 - 冇钱;冇房子;冇成就。要吃饭;要住宿;要消费

赞同来自:

额。。。。那我研究下LuManager 了。。。

要回复问题请先登录注册