安装joomla是非常简单的,只要你的环境配置都没有问题,那么安装joomla就手到擒来。在这节中,我们将讨论一下Joomla3x的安装环境要求。

环境要求:

不管你是在本地安装Joomla或者是在空间提供商空间上安装Joomla ,你都必须确认下面的几个方面:

1,PHP的版本是否满足joomla的最低版本

Joomla是用php写的。对php的版本有很高的依赖,如果版本不对,那么就会出现很多错误,导致Joomla完全不能正常运行。

Joomla 3x对PHP的最低版本要求为5.3.10+(官网是这么标注的,个人还不清楚这个是否包含5.3.10),不管怎样,我们安装的PHP版本只要高于5.3.10,那么肯定OK.

Joomla3x 官方推荐的PHP版本为5.5+ 。在这个版本上,Joomla将由最好的性能。

以上两个版本中都要求魔术引号被关闭。(默认情况下就是关闭的)

2,数据库是否满足要求

Joomla支持MySQL数据库,MSSQL ,PostgreSQL。在这个3个当中用得最多就是MySQL了。

MySQL的最低版本要求为5.1+ 推荐的版本为5.1+ 。

MSQL 的最低版本要求为10.50.1600.1+  推荐使用的版本为10.50.1600.1+

PostgreSQL 的最低版本要求为8.3.18+ 推荐版本为8.3.18+

一般情况下我们都是使用MySQL的。需要注意的是,Mysql必须支持(InnoBD引擎)

3,Web服务器的要求

可用的Web服务器有如下的几个:Apache, Hiawatha ,Nginx ,Microsoft IIS.在这些服务器程序中Apache是最受欢迎的,目前Nginx感觉也慢慢的崛起。

Apache的最低版本为2.x+ ,推荐的版本为2.x+ 

Hiawatha的最低版本为8.0,推荐使用最新版本

Nginx 的最低版本为1.0  ,推荐使用的版本为1.1

Microsoft IIS 的最低班委7 ,推荐版本为7

一般我们使用Apche作为服务器,我们需要注意的是Apche需要支持(mod_mysql ,mod_xml ,和 mod_zlib)这三个模块,否则使用会很痛苦。(本人曾经使用华夏名网的主机,当时就不支持zlib库,最后每次安装扩展都需要在本地安装好,然后将网站备份在上传,想起来就是一场噩梦)

另外,需要注意的是如果你需要使用搜索引擎友好功能,你需要确保apache的mod_rewrite模块被正常加载。

在Joomla官网上存在下面的一段话,由于本人没有体会,就原样摘抄:

 The mod_suphp extension or mod_fcgid extension is recommended to enable Joomla to upload and execute files using secure file permissions.

 

 

 

用户评分: 0 / 5

不活动星星不活动星星不活动星星不活动星星不活动星星
 

评论

  • 未找到评论